b1gMailServer 2.8.3283

patrick

Staff member
B1G-Software-Kunde
#1
b1gMailServer 2.8.3283 für b1gMail 7.2/7.3/7.4 steht nun zum Download bereit.

Wichtig: Diese b1gMailServer-Version ist ausschließlich mit b1gMail 7.2, 7.3 und 7.4 kompatibel.

Änderungen 2.8.3277-> 2.8.3283
* Problem behoben, bei dem IMAP FETCH BODY[n] den Read-Only-Modus nicht beachtet hat
* Problem behoben, bei dem IMAP SEARCH mit bestimmten Sequenz-Sets nicht korrekt funktionierte
* Handling von IMAP-String-Literals verbessert
* Milter-Integration unterstützt nun das auth_type-Makro
* Problem mit fehlendem OpenSSL applink unter WIndows gelöst
* Verschiedene Verbesserungen und Optimierungen
Neuinstallation
Falls noch nicht geschehen, auf b1gMail 7.2 oder höher aktualisieren (empfohlen: b1gMail 7.3).

Bitte der Installations-Anleitung folgen, die im Wiki zu finden ist.

Update von Version 2.5/2.6/2.7
Falls noch nicht geschehen, auf b1gMail 7.2 oder höher aktualisieren (empfohlen: b1gMail 7.3).

Downloadarchiv im Kundencenter herunterladen, "liesmich.html" lesen

Hinweise:
  • Vor Update bitte zuerst, falls nötig, das Admin-Plugin aktualisieren (siehe Liesmich-Datei).
  • Die Dokumentation ist immer aktuell im Wiki einsehbar: http://wiki.b1gmail.com/wiki/b1gMailServer
  • Zur Nutzung der neuen Autodiscover-/Autoconfig-Funktion sind nach dem Update noch weitere Schritte nötig
  • Für Apple-Push-Support ist ein Zertifikat von Apple erforderlich (mehr Infos siehe hier)
  • Für die ARM-Version empfehlen wir Debian 8 (Jessie)
  • Die Linux-Versionen enthalten ab sofort im ZIP-Archiv einen Ordner "plugins" mit aktuellen Builds des Signatur- und CleverMailEncryption-Plugins.
 

Eligi

B1G-Software-Kunde
#3
Ich bin heute von b1gMailServer 2.8.3269 auf b1gMailServer 2.8.3283 gewechselt. Jeweils Linux 64bit.

Nun erhalten alle E-Mail-Benutzer (unabhängig, über welchen Client oder ob die E-Mail über das Webinterface versendet wurde) von verschiedenen Empfängern folgenden "Invalid HELO name"-Fehler zurück (ein Beispiel):

----- Error description -----
mx02.secure-mailgate.com: Server rejected recipient.
Server answered: "550 Access denied - Invalid HELO name (See RFC5321 4.1.1.1)"

----- The message was not delivered to the following addresses -----
Das Log dazu sieht z.B. so aus:

MSGQueue#13651 - Queue message 00013B50 (80720; type: 0) processed successfuly: Delivered to b1gMail pipe.Heute, 22:24:19
MSGQueue#13651 - Fatal error while processing queue message 00013B4F (80719; type: 1; status: 3): mx01.secure-mailgate.com: Server rejected recipient. Server answered: "550 Access denied - Invalid HELO name (See RFC5321 4.1.1.1)"; bouncedHeute, 22:24:19
MSGQueue#13651 - Bounced message 80719, bounce queue id: 80720
Ich hatte keine anderen Umstellungen ausser diesem Update. SPF-Record usw. sind seit längerer Zeit unverändert. Gemäss meinen Recherchen kommt der Fehler insb. dann vor, wenn der SMTP Auth nicht korrekt ist.

Unter Adminbereich unter "Einstellungen" -> "E-Mail" -> "Versand" ist als "Versand-Methode" SMTP eingetragen, die Settings zu SMTP sind leer (bis auf localhost:25). Meinem Verständnis nach sind diese Settings aber irrelevant, wenn b1gMailServer die Auslieferung selbst vornimmt. Oder sind diese dennoch relevant? Falls ja, wie müssten diese eingestellt sein? Oder müsste hier als "Versand-Methode", analog zum Empfang, auch irgendwie b1gMailServer auswählbar sein?

Unter "Plugins" -> "b1gMailServer" -> "E-Mail-Verarbeitung" -> "Ausgehende E-Mails" ist unter "Verarbeitung" dann "Mails selbst ausliefern" eingetragen. Weitere Settings habe ich ja dort nicht.

Hat jemand dieses Problem auch? Oder kann mir hier jemand weiterhelfen, an was es liegen könnte?

Danke vielmals für jede Unterstützung. Aktuell ist der E-Mail-Versand total lahmgelegt... :-/
 
Last edited:

patrick

Staff member
B1G-Software-Kunde
#4
Vermutlich hast du irgendwann mal unter Einstellungen -> Allgemein den Hostnamen angepasst (evtl. versehentlich oder auch durch Auto Complete vom Browser) und erst jetzt durch das Update wurde der Queue-Dienst neu gestartet und die Änderung übernommen.

Stelle bitte sicher, dass dort der Hostname des Servers eingestellt ist, der auch mit dem Reverse-DNS deiner Server-IP übereinstimmt und starte nach Korrektur den Warteschleifendienst erneut.
 

Eligi

B1G-Software-Kunde
#5
Stelle bitte sicher, dass dort der Hostname des Servers eingestellt ist, der auch mit dem Reverse-DNS deiner Server-IP übereinstimmt und starte nach Korrektur den Warteschleifendienst erneut.
Danke für die zügige Unterstützung, funktioniert seit der Änderung am Mittwoch wieder.
 
Top