Kunden-Center
  #61  
Alt 05.02.2017, 09:24
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
Welche Version arbeitet noch am besten mit dem aktuellen Backendprovider

Hallo Zusammen,

kann mir jemand sagen mit welcher Version von Z-Pusch der Backendprovider am besten zusammenarbeitet?

Da Z-Push ja bereits bei der Version 2.3.4 ist und der B1GMail Provider noch bei der Version 2.2 ist...

Habe jetzt Z-Push 2.3.4 mit dem derzeit aktuellen Backendprovider von B1gMail. Aber dort erhalte ich nach dem login folgende Fehlermeldungen:

PHP-Code:
Z-Push Open Source ActiveSync

Version 2.3.4
FatalMisconfigurationException

PHP
-MAPI extension is not available

Trace
:
Array
(
    [
0] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/backend/kopano/kopano.php
            
[line] => 35
            
[function] => include_once
        )

    [
1] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/vendor/composer/ClassLoader.php
            
[line] => 412
            
[args] => Array
                (
                    [
0] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/backend/kopano/kopano.php
                
)

            [function] => include
        )

    [
2] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/vendor/composer/ClassLoader.php
            
[line] => 301
            
[function] => Composer\Autoload\includeFile
            
[args] => Array
                (
                    [
0] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/vendor/composer/../../backend/kopano/kopano.php
                
)

        )

    [
3] => Array
        (
            [function] => 
loadClass
            
[class] => Composer\Autoload\ClassLoader
            
[type] => ->
            [
args] => Array
                (
                    [
0] => BackendKopano
                
)

        )

    [
4] => Array
        (
            [function] => 
spl_autoload_call
            
[args] => Array
                (
                    [
0] => BackendKopano
                
)

        )

    [
5] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/lib/core/zpush.php
            
[line] => 575
            
[function] => class_exists
            
[args] => Array
                (
                    [
0] => BackendKopano
                
)

        )

    [
6] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/lib/core/zpush.php
            
[line] => 425
            
[function] => GetBackend
            
[class] => ZPush
            
[type] => ::
            [
args] => Array
                (
                )

        )

    [
7] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/lib/core/zpush.php
            
[line] => 410
            
[function] => GetStateMachine
            
[class] => ZPush
            
[type] => ::
            [
args] => Array
                (
                )

        )

    [
8] => Array
        (
            [
file] => /var/www/vhosts/xxx.de/httpdocs/Microsoft-Server-ActiveSync/index.php
            
[line] => 64
            
[function] => CheckAdvancedConfig
            
[class] => ZPush
            
[type] => ::
            [
args] => Array
                (
                )

        )



Gruß
OYO
Mit Zitat antworten
  #62  
Alt 05.02.2017, 12:20
Benutzerbild von patrick
patrick patrick ist offline
B1G-Software-Kunde
 
Registriert seit: 03.2003
Ort: Meppen
Beiträge: 11,554
Der Z-Push-Connector ist noch nicht mit b1gMail 7.4 / Z-Push 2.3 kompatibel. (Wird demnächst aktualisiert.)

Die Meldung besagt aber, dass die PHP-MAPI-Erweiterung bei dir auf dem Server fehlt.

@ExHive?: Danke für dein Feedback!
__________________
Patrick Schlangen
B1G Software

Entwicklungsstatus

B1G Kundencenter | FAQ | Hilfe | cron-job.org | b1gMail bei Facebook

Kein Support per Foren-PN!

Geändert von patrick (05.02.2017 um 12:31 Uhr)
Mit Zitat antworten
  #63  
Alt 05.02.2017, 13:29
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
Hallo Patrick,

das hab ich soweit auch schon ergoogelt.
Wie kann ich denn, die PHP-Mapi Erweiterung für PHP 5.6.30 nachinstallieren.
Bisher habe ich nur Info´s gefunden wonach ich wieder auf PHP 5.4 zurück versionieren muss... Ob das so sinnig ist???

Gruß
OYO

EDIT:
Soweit ich lesen konnte ist PHP-Mapi eine Erweiterung für Zaraffa selbst, stellt sich also die Frage ob das für B1G-Mail benötigt wird. Da diese Erweiterung in den Zaraffa Paketen zu finden sind um die Schnittstellen zu Kopano implementieren zu können (so in etwa zumindest war es heraus zu lesen). PHP-Mapi wird aber soweit ich, lesen konnte und es auch als solches verstanden habe) nicht mehr in den PHP-Paketen unterstütz.

Gruß
OYO

Geändert von oyoony (05.02.2017 um 14:52 Uhr)
Mit Zitat antworten
  #64  
Alt 05.02.2017, 15:54
Benutzerbild von patrick
patrick patrick ist offline
B1G-Software-Kunde
 
Registriert seit: 03.2003
Ort: Meppen
Beiträge: 11,554
Erste Version mit experimentellem Support für b1gMail 7.4 und Z-Push 2.3 gibt's nun in folgendem Branch: https://github.com/b1gMail/zpush-b1g...-23-b1gmail-74

Achtung, diese Version funktioniert nur mit Z-Push 2.3 und b1gMail >= 7.4.0-Beta3.

Feedback ist willkommen.

@oyoony: Bei mir läuft es problemlos auch ohne MAPI-Erweiterung mit Z-Push 2.3. Hast du in der config.php korrekt das b1gMail-Backend aktiviert? Sieht nach deinem Backtrace so aus, als wenn du das kopano-Backend verwendest.
__________________
Patrick Schlangen
B1G Software

Entwicklungsstatus

B1G Kundencenter | FAQ | Hilfe | cron-job.org | b1gMail bei Facebook

Kein Support per Foren-PN!
Mit Zitat antworten
  #65  
Alt 05.02.2017, 16:11
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
Hallo Patrick,

also, wenn dann müsste es an dem alten Backendprovider liegen.
Ich probier das gleich mal mit deiner Version aus und melde mich dann wieder...


Gruß
Oyo
Mit Zitat antworten
  #66  
Alt 05.02.2017, 16:12
Benutzerbild von patrick
patrick patrick ist offline
B1G-Software-Kunde
 
Registriert seit: 03.2003
Ort: Meppen
Beiträge: 11,554
Zitat:
Zitat von oyoony Beitrag anzeigen
also, wenn dann müsste es an dem alten Backendprovider liegen.
Kann ich mir nicht vorstellen. In der von dir geposteten Meldung wird deutlich, dass Z-Push eindeutig das falsche Backend lädt. Der Fehler entsteht also schon, bevor das b1gMail-Backend überhaupt geladen wird.
__________________
Patrick Schlangen
B1G Software

Entwicklungsstatus

B1G Kundencenter | FAQ | Hilfe | cron-job.org | b1gMail bei Facebook

Kein Support per Foren-PN!
Mit Zitat antworten
  #67  
Alt 05.02.2017, 16:31
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
Also ich habe eben alles neu installiert.
Fehlermeldung ist die selbe...
hab dir mal per Mail die Logs geschickt.
und schick dir gleich noch di Config per Mail

Gruss OYO
Mit Zitat antworten
  #68  
Alt 05.02.2017, 21:02
Benutzerbild von patrick
patrick patrick ist offline
B1G-Software-Kunde
 
Registriert seit: 03.2003
Ort: Meppen
Beiträge: 11,554
Sache ist nun geklärt, es lag an einer falschen Konfiguration...
__________________
Patrick Schlangen
B1G Software

Entwicklungsstatus

B1G Kundencenter | FAQ | Hilfe | cron-job.org | b1gMail bei Facebook

Kein Support per Foren-PN!
Mit Zitat antworten
  #69  
Alt 05.02.2017, 21:14
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
So, also über den Browser komme ich zum Test rein.
Will ich mich aber nun mit meinem Tab oder meinem Smartphone einloggen, funzt dit nüscht...

In den Logfiles wird zwar 200 OK angezeigt, aber ich komme nicht zum Administrator weiter um die Enrichtung ab zu schließen.

Beide Geräte verwenden Android 6

Gruß
OYO
Mit Zitat antworten
  #70  
Alt 05.02.2017, 21:49
Benutzerbild von GenXRoad
GenXRoad GenXRoad ist offline
B1G-Software-Kunde
 
Registriert seit: 04.2008
Ort: Worms
Beiträge: 1,011
GenXRoad eine Nachricht über ICQ schicken GenXRoad eine Nachricht über MSN schicken GenXRoad eine Nachricht über Skype™ schicken
hast du eingestellt das die komplette email verwendet werden muss oder nur der nuztername?


dann kann man sich soweit ich weiss nur mit der "Hauptemail" anmelden nicht mit einem Alias
__________________
OS: Linux 3.7.10-1.24-desktop on x86_64 | Intel(R) Xeon(R) CPU E3-1240 V2 @ 3.40GHz, 8 cores | 32 GB DDR3 ECC Registered | 2x 3000 GB HDD Raid 1 | Apache: 2.2.22-10.8.1 | PHP: 5.3.17-3.8.1 | MariaDB: 5.5.33-1.16.1 | B1gMail 7.3.0 PL3 | B1gMailServer: 2.7.3095 Professional
Mit Zitat antworten
  #71  
Alt 05.02.2017, 21:59
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
@GenXRoad

Ja habe meine Komplette Mailadresse und das richtige Passwort angegeben.

Und
Zitat:
define('USE_FULLEMAIL_FOR_LOGIN', true);
Was mir noch aufgefallen ist, dass ich mit meinem Tab damit die Logfiles auslöse. Aber wenn ich mich mit dem HTC M9 versuche ein zu loggen, dann überhaupt nix passiert...

Sehr merkwürdig...
Mit Zitat antworten
  #72  
Alt 06.02.2017, 02:23
Benutzerbild von GenXRoad
GenXRoad GenXRoad ist offline
B1G-Software-Kunde
 
Registriert seit: 04.2008
Ort: Worms
Beiträge: 1,011
GenXRoad eine Nachricht über ICQ schicken GenXRoad eine Nachricht über MSN schicken GenXRoad eine Nachricht über Skype™ schicken
Zitat:
Zitat von oyoony Beitrag anzeigen
@GenXRoad

Ja habe meine Komplette Mailadresse und das richtige Passwort angegeben.

Und

Was mir noch aufgefallen ist, dass ich mit meinem Tab damit die Logfiles auslöse. Aber wenn ich mich mit dem HTC M9 versuche ein zu loggen, dann überhaupt nix passiert...

Sehr merkwürdig...
Auch den Hauptbenutzer und kein Alias? Das hatte ich mal irgendwie das es deswegen nicht funktioniert hatte
__________________
OS: Linux 3.7.10-1.24-desktop on x86_64 | Intel(R) Xeon(R) CPU E3-1240 V2 @ 3.40GHz, 8 cores | 32 GB DDR3 ECC Registered | 2x 3000 GB HDD Raid 1 | Apache: 2.2.22-10.8.1 | PHP: 5.3.17-3.8.1 | MariaDB: 5.5.33-1.16.1 | B1gMail 7.3.0 PL3 | B1gMailServer: 2.7.3095 Professional
Mit Zitat antworten
  #73  
Alt 06.02.2017, 06:02
Holger Holger ist offline
B1G-Software-Kunde
 
Registriert seit: 08.2004
Beiträge: 51
Problem Ordner laden in der Mailübersicht

Hallo,

ich habe das Problem seit der Version 7.4, das ich die Order nicht mehr laden kann direkt in der Mailansicht. Wenn ich einen Ordner anklicke kommt immer nur der Spinner und passieren tut nichts mehr.

Ich muss dann oben links bei "neue E-Mail" auf Ordnerverwaltung klicken und dort dann den Ordner auswählen welchen ich möchte.

Geht nicht im IE11 / FF51 Windows / Mac

Geändert von Holger (06.02.2017 um 08:57 Uhr) Grund: Version auf 7.4 angepaßt
Mit Zitat antworten
  #74  
Alt 06.02.2017, 06:28
Benutzerbild von patrick
patrick patrick ist offline
B1G-Software-Kunde
 
Registriert seit: 03.2003
Ort: Meppen
Beiträge: 11,554
@Holger: Meinst du Version 7.4 oder wirklich 7.3?

Es gab da mal ein Problem in der 7.4.0 Beta 1, das aber nun behoben ist. Falls es bei dir immer noch Auftritt in Beta 2/3, wäre Testlogin per PM sehr hilfreich. Dann kann ich es mir mal ansehen.
__________________
Patrick Schlangen
B1G Software

Entwicklungsstatus

B1G Kundencenter | FAQ | Hilfe | cron-job.org | b1gMail bei Facebook

Kein Support per Foren-PN!
Mit Zitat antworten
  #75  
Alt 06.02.2017, 08:20
oyoony oyoony ist offline
B1G-Software-Kunde
 
Registriert seit: 11.2011
Beiträge: 193
@GenXRoad

Ja das ist meine Haupt e-Mail Adresse die beim Anlegen des Accounts erstellt wurde.

vorname.nachname@domain.de

Wie gesagt, mit meinem TAB und mit meinem HTC M9 funktioniert das nicht. Wobei mit dem TAB in der zpush.log ein Eintrag ausgelöst wird, die zpush-error.log, users und settings aber jungfäulich bleiben.

Beim HTC M9 bleiben alle logs jungfräulich

TAB zpush.log sieht dann so aus:

Zitat:
05/02/2017 22:47:25 [15966] [ INFO] [andre.goetz@oyoony.de] FileStateMachine->SetStateVersion() saving supported state version, value '2'
05/02/2017 22:47:25 [15966] [ INFO] [andre.goetz@oyoony.de] User-agent: 'Android-Mail/7.1.15.145691033.release'
05/02/2017 22:47:25 [15966] [ INFO] [andre.goetz@oyoony.de] cmd='' memory='2.29 MiB/2.75 MiB' time='0.04s' devType='' devId='' getUser='andre.goetz@oyoony.de' from='77.180.184.66' version='2.3.4' method='GET' httpcode='200'
05/02/2017 22:48:17 [16487] [ INFO] [andre.goetz@oyoony.de] User-agent: 'Android-Mail/7.1.15.145691033.release'
05/02/2017 22:48:17 [16487] [ INFO] [andre.goetz@oyoony.de] cmd='' memory='2.29 MiB/2.75 MiB' time='0.04s' devType='' devId='' getUser='andre.goetz@oyoony.de' from='77.180.184.66' version='2.3.4' method='GET' httpcode='200'
05/02/2017 22:49:27 [16859] [ INFO] [andre.goetz@oyoony.de] User-agent: 'Android-Mail/7.1.15.145691033.release'
05/02/2017 22:49:27 [16859] [ INFO] [andre.goetz@oyoony.de] cmd='' memory='2.29 MiB/2.75 MiB' time='0.04s' devType='' devId='' getUser='andre.goetz@oyoony.de' from='77.180.184.66' version='2.3.4' method='GET' httpcode='200'
HTC M9 und Tablet verwenden beide Android 6 als ROM original vom Hersteller.

Ich muss mal warten bis meine Tochter zurück ist, die hat nen Iphone.
Dann kann ich das auch nochmal auf dem Iphone testen.

Gruß
OYO
Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 19:20 Uhr.